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Procedure for Adding the Mapunit Key and Mapunit Name Fields to the Spatial Data
Attribute Table for Progressive Soil Surveys

The mapunit key (mukey) field needs to be in the spatial data attribute table in order to use the Soill
Data Viewer ArcGIS extension. It is also very useful when working with spatial and tabular data
that contains more than one subset survey area. The mukey is unique nationally. Every mapunit
in each NASIS legend has a unique mukey. The mukey originates from the NASIS mapunit record
ID (muiid) in the Mapunit table. It is stored in NASIS as an integer but is converted to text (30
characters) with a SSURGO export from NASIS.

The following are steps that can be used to add the mukey and muname fields to the spatial
attribute table for progressive soil surveys:

1. Load the data for the soil survey into a NASIS selected set. Use a query that will load all the
mapunits that are in the spatial data. An MO-1 query that can be used is “Load Major
Components (all objects) by area symbol”. Set target tables to Area, Legend, Component to
load all mapunits, including additional symbols - this will load only major components. To
include minor components, set the target tables to Area, Legend, Data Mapunit.

2. In NASIS click on File > Export > SSURGO format. The following dialog box will appear:

SSURGO Exporl Manager
Choose mapunits for legends in the selected set, based on:

“* Hapunits in selected set

+ Hapunits from pernanent tables with status of:

A Frovisionsl J Spproved  forrelsted | Biditional

Choose data mapunits based on:
“* Data napunits in selected set
+ A1l data mapunits from pernanent tables

+ Data mapunits fron pernanent tables with certification status of:

A et Pee Siebrdbstios J Heb Certifisd  Partly feriifisd Jieriified

For napunits with additional status:
“* Use representative data mapunit to which correlated

+ Use representative data napunit for additional mapunit

Choose components based on:

“* Conponents in selected set

+ A1l conponents fron permnanent tables Use the Settlngs |n the example '[O
v Hajor conponents from pernanent tables the left. Your e-mail address
+ Cony ts from per t tables with ¥ comp greater or equal to Ig:_per‘cent. ShOU|d appear The State dlreCtOFy
Select/View Inter‘pr‘etatiuns” | Select/Yiew Text Kinds || ShOUId aUtO poleIatea based on the
’—[ location of the survey area. The
Enail MHotification HAddress: I:*st,eue.campbell@or‘usda‘gau “Selectlvlew Interpretatlonsu button
Choose State Directory: or 7|Export File nane: [DRE1S g2 can be used to add interpretations

1 IRun Expor‘tl Cancel I| | Help I| + to the eXport

More information on SSURGO exports from NASIS is available in the NASIS tutorial manual at
ftp://ftp-fc.sc.egov.usda.gov/NASIS/documents/tutorial5/5n8.pdf. Click the “Run Export” button
after you've selected all the desired settings. You will receive an e-mail message, generally within
an hour, when the SSURGO export is ready to download.



ftp://ftp-fc.sc.egov.usda.gov/NASIS/documents/tutorial5/5n8.pdf
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3. In NASIS click on File > Download. The following File Copy Manager dialog box will appear:

NASK File Copy Manager- X
HASIS Server Horkstation il
/ 4
Left double click on the SSURGO folder under the Focs/ c/ A
NASIS Server heading, then scroll down to the local/ Ej
applicable State folder. Double click on the State ( ssugﬁufs | lw
folder. I £ ii
For each SSURGO export there will be two files, K/
one with a .gz extension, and another with a .txt & i
extension, as in the example below. The file with 17
the .gz extension contains the exported data. This  Text file transfer
is a compressed file similar to a zip file. The .txt file | I_l
has information about the export that is identical to : fapcel] | Eebe .

the text in the NASIS export e-mail message.

il ki’ el Click on the .gz file you want to download,

HASIS Server Horkstation ) ]
7SSURGDZors 7 and then left double click on the Workstation
wd ] c/ drive letter where you want to download the
BLHT_7_2009,.g= (3484 KB 07/21/09) s 1 i
BLNT 7 2009, tat €1 KB 07/21709) . file. It is recommended that you create an
DR618_9_2009,gz (1449 KB 07/21709) B | My empty folder on your computer to save the
ORE618_9_2009,txt {1 KB 07/21/09} - I/ 1 i i i
ORE27-7.00 cn (1379 KB 07¢21709) | v -9z file in. Navigate to this folder.. When the
ORG27_7_2009, txt €1 KB 07/21/09) K/ file to download and the workstation folder
e L e are selected, click the right arrow button.
ORE44_7_2009,txt (1 KB 07/21709) 57 ) o , » .
OR677_7_2009.gz {886 KB 07/21/09) ||, ¥/ Don't select the “Text file transfer” option”.

i Text file transfer More information on downloading NASIS files

Cncel || |__tele | is available at:

http://soils.usda.gov/technical/nasis/products/citrixinfo.html.

4. The next step is to extract the files in the .gz file. Locate the file in Windows Explorer, right
click on the file, select WinZip > Extract to here. The following dialog box will appear. Click

“Yes”.
WinZip 5¢)
2 Archive contains one file:

—

ORB18_9_2009 tar

Should Winip decompress itto atemporary folder and open it?

WinZip will extract a number of text files that contain the exported NASIS data. Additional
information on working with NASIS exports is available at:

http://soils.usda.gov/technical/nasis/products/nasisexport50.html.



http://soils.usda.gov/technical/nasis/products/citrixinfo.html
http://soils.usda.gov/technical/nasis/products/nasisexport50.html
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5. Obtain a SSURGO Microsoft Access template to import the text files into. Templates are
available for Idaho, Oregon, and Washington from the MO-1 web site at:

http://www.or.nrcs.usda.gov/pnw_soil/mo1 templates.html

Save the template zipfile in the same folder as the NASIS export text files. Use WinZip to
extract the template. Rename the template file using a convention with the soil survey area
symbol and the date. An example would be “or618_d_7_2009”. The “d” is the SSURGO
convention for database files.

6. Left double click the Access template file to open it. When the file opens, the following dialog
box will appear. It is asking for the path where the NASIS export text files are located. The
easiest way to obtain this is to go back to Windows Explorer and copy the path in the Address
box, then right click and paste into the SSURGO import box. Then click OK. The template will
begin importing the text files. This process can take up to 5 minutes, depending on the number
of mapunits and components in the survey area.

SSURGO Import (Template Version 33 - Oregon v. 2]

Mote: This function imports the tabular data contained in a soil data
download into this database. For detailed instructions, please select the
Reports tab of the Database window, open the report titled "How to
Understand and Use this Database”, and read the section titled "Importing
Data®.

Enter the directary location where the files to be imparted reside.  Enter both the

the letter of the drive and the fully gualified path to the directory on that drive. For
example "ditmplsoil_mtE2 tabalan®. The closing backslash is optional.

ok | Cancel |

7. When the process in Step 6 is complete, the “mapunit” table in the Access template will be
populated with the mapunit symbol (musym), mapunit key (mukey) and mapunit name. See
the example below:

File Edit “iew |nset Format Becords Tools Window Help  Adohe PDF
mapunithi_r * | Arial
B-1H0 G0 T 3 AR ARA-! "éévvn-_i‘lrf_élv-@li
& mapunit : Table
Mapunit Symbal | Mapunit Key Mapunit MName Status Kind

| =214 1015235 Blancocanyon ashy loam, 0 to 5 percent slopes Approved Consociation
| |#245 1015456 Anatone-Ateron-Polkbutte complesx, 12 to 30 percent north s Provisional Complex
| |+ 246 1015478 Anatone-Ateron-Polkbutte complesx, 30 to 65 percent north s Provisional Complex
||+ 247 1015479 Anatone-Ateron complex, 12 to 30 percent south slopes Approved Cormplesx
||+ 248 1015519 Anatone-Ateron complex, 30 to BS percent south slopes Approved Complex
||+ 248 1015538 Embal-Luckycreek complex, 0to 5 percent slopes Additional Complex
| |+ 250 1015539 Luckycreek-Polkbutte complesx, 0 to 5 percent slopes Pravisional Complex
| | 263 1015546 Finsel-Royst-Polkbutte cormplex, 12 to 30 percent north slop Provisional Complex
| |+ 264 1015551 Finsel-Polkbutte complex, 30 to B5 percent north slopes Provisional Complex
| |#265 1015558 Bonnieview- Observation-Anatone complex, 12 to 30 percent | Provisional Cornplex
|| 266 1015563 Erakatak-Tuscor-Anatone complex, 30 to B5 percent south € Approved Complex
|| 267 1015568 Bonnieview-Bonnieview, thin surface, complex, 0 to 12 perce Provisional Complex
| | 268 1015578 Bonnieview clay loam, depressional, 0 to 5 percent slopes | Provisional Consociation
||+ 269 1015581 Powellbutte-Bonnieview, thin surface-Bonnieview complex, 0 Provisional Complex
| |# 270 1015582 Bonnieview, depressional-Luckycreek complex, 0 to 5 perce| Provisional Complex
#1131 1015683 Lickskillet-Badlands complex, 15 to 70 percent south slopes Approved Complex

+ 344000 1017187 Maucav-Yawkey-Sintuf complex, 30 to B0 percent slopes Provigional Complex



http://www.or.nrcs.usda.gov/pnw_soil/mo1_templates.html
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8. Start ArcMap and add the spatial data for your survey area. Right click on the layer. Select
Joins and Relates > Join. The following dialog box will appear:

Join Data x|

Jiin lets you append additional data to thiz layer's attibute table so pou can, Use the MUSYM
for example, spmbolize the layer's features uging thiz data. /

field from the

Wwhat do pou want to join to this layer? spatial data for the
Join attribul join.
1. Choose the field in thiWIl be based on: Click on the browse button
MUSYM & =] and browse to the Access

database created in Step 6.
Double click on the Access
2. Chooze the table ta join ta thiz layer, or load the table from dizk: 1 database file name and all
;J the table names will appear.

Click on the “mapunit” table
then click “Add”.

| mapunit
¥ Show the attibute tables of layers in this list

3. Choose the field in the table to base the join on:

ALIZYM =] Use the MUSYM
= N field from the
mapunit table for

the join
Advanced... |

Click OK. A message may appear
about indexing to improve
performance. Click OK to create
index.

About Joining D1ata | )4 I Cancel 4-/

9. Open the attribute table and sort ascending by mukey. A null mukey for a polygon indicates
that the mapunit is not in the NASIS legend. These mapunits should be added to NASIS or the
spatial mapunit symbol (musym) should be corrected for incorrectly attributed polygons.

@ Attributes of OR618_03052009 - [O] x|
OR618_03052009.MUSYM mapunit.musym * punit mapunit.mustatus mapunit. mukey * &
177780 =hlull= =hlull= =hull= =Mull= |
173840 =hlull= =hlull= =hull= =hull=
F443M0 =hlull= =hlull= =hull= =hull=
345140 =hlull= =hull= =hull= =hull=
K 178240 =hjull= =hull= =hull= =hlull=
Ja44.40 =hjull= =hull= =hull= =hlull=
17930 =hjull= =hull= =hull= =hlull=
343600 =hjull= =hull= =hull= =hlull=
173300 =hlull= =hlull= =hull= =hlull=
34430 =hlull= =Mull= =hull= =hlull=
174 =hlull= =Mull= =hull= =hlull=
174 =hlull= =Mull= =hull= =hlull=
343880 =hlull= =hull= =hull= =hlull=
34430 =hull= =hull= =Pull= =hlull=
e 3R =hull= =hull= =Plull= =hlull=
3443H0 =hull= =hull= =Plull= =hlull=
343880 =Mull= =<Mull= =Pull= =Mull=
3443N0 =Mull= =<Mull= =Pull= =Mull=
178120 =Mull= =<Mull= =Pull= =Mull=
173000 =hlull= =hlull= =hull= =Mull=
473000 =Mull= =Mull= =Mull= =l =
'I [ ol
Record: ﬂjl 5 jﬂ Shiows: W Selected | Records (0 out of 12496 Selected) Options v|
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10. The next step is to export the spatial layer out as a new feature class or shapefile. Soil Data
Viewer requires a shapefile. First we’re going to select the attribute fields we want to include in
the attribute table of the new spatial layer. Right click on the spatial layer, select “Properties”,
then click on the “Fields” tab. Suggested fields to include are the “musym” from the spatial
layer, and the following from the mapunit table: musym, muname, mustatus, and mukey.

Layer Properties 7 x|

Generall Sourcel Selectionl Displa_l,.ll Symbaology  Fields |Definition Quer_l,ll Lahelsl Joins&HeIatesI

Erimary Display Field: 09.MUSYk

T . o _ / When the mapunit table is
Choosge which fields will be visible. Click in the alias column to edit the alias for any field. .. .

1 joined to the spatial layer, a

Mame | Aliaz I Type I Length | Precizion I !7'/ number Of fleldS are added to
¥l OR616_03052009.MUSYM ORE18_0305200... Text 10 o the attribute table that may
Wl ORE18_ 03052009 F45_LABEL ORE18_0305200... Text [ not be needed. The “Clear
M oRet 8_03052009.5hape_Leng ORE18_0305200... Double g i All” button can be used to
ORE18_03052009 Acres ORE18_0305200... Float 4 i unselect all the fields. then
DHB‘I8_03052009.Shape_Length Shape_Length uble: 8 0 the desired fle'dS can, be
I:IF!B‘IS_DBDEZDDS.Shape_.&rea Double 8 0 selected by CliCking the box
lmapun"'musy " e ° _'D|j to the left of the field name

Selectal | Clearsl A}/

QK. I Cancel | Apply |

11. Right click on the spatial layer in the table of contents, select Data > Export Data. The dialog
box below on the left will appear. The layer can be exported into an existing personal or file
geodatabase, or as a shapefile. If you want to use the layer with Soil Data Viewer it needs to
be a shapefile.

Export Data jd 73 | Saving Data x|

Lookin: (23 JayPrefim_7_2003 - = ] a

Expart: IAII features ;I I J —I glgl—l —DI
MName | Type |

Uze the zame coordinate system asz [dPreliminary_tabular_data_J.. Folder

% thiz layer's source data

™ the data frame

) thefeatire dataset o erport the data into

[l apElies i yew edpert o & (e ature dataset it & aend atatiaee]

Output shapefile or feature class:

IK:'\.J ayPrelim_7_2003%z0imu_a_orB18_S0V.shp
Hame: Isoilmu_a_DrB‘I 8 5DV shp
Sa s type: IShapefiIe LI Cancel |

File and Perzonal Geodatabase feature classes
(] I Cancel .
The browse button will open

the dialog box above right.
The file name and folder
location can be set, and the
file type (shapefile or feature
class) can be selected.
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12. See the image below. The attribute table of the new layer created in step 11 above has a
column named “MUSYM?” that came from the original spatial layer. It has a field length of 10
characters. Soil Data Viewer requires a text (string) field named “musym” with a length of 6

characters. The musym_

1 field came from the joined “mapunit” table and has a length of 6

characters.

B8 Attributes of soilmu_a_or618_SDV _ (O] x|
FID Shape * FMUSYM ] musym_1 muname mustatus | mukey ~ |
0 |Polygon 194m 194m Borohey ashy sandy loam, 0to 5 percert slopes Approved 75457 =

1 |Paolygan 93Bm 93B8m Minemile-Dester complex, 110 § percent slopes Approved 75472

2 |Polygon 93Bm 93Bm Minemile-Dester complex, 1 to § percent slopes Approved T5472

3 |Polygon 095 095 Etakatak-Ateron complex, 40 to 70 percent south slopes Approved 78390

4 |Palygan o070 o7 Simas-Sorf complex, 12 ta 30 percent south slopes Approved 75586

5 |Polygon 030 030 Polly loam, 1 to 15 percent slopes Approved 75385

B |Polygon 204 204 Ayres cobbly loam, moist, 3to 8 percent slopes Approved 17866

7 |Paolygan 161 161 Lickskillet-Fock outcrop-Searles complex, 40 to 50 percent south slopes Approved 75435

§ |Polygon 030 030 Polly loam, 1 to 15 percent slopes Approved 75385

9 |Polygon 030 030 Pally loam, 1 to 15 percent slopes Approved 78385

10 |Palygon 055 055 Erakstak-Ateron complex, 12 to 30 percent south slopes Approved TE412

11 |Palygon 091 091 Bonnieview-Polkbutte complex, 5 to 40 percent north slopes Provizional 78386

12 [Palygon 095 095 Etakatak-Ateron complex, 40 to 70 percent south slopes Approved 78390

13 |Palygon 091 091 Bonnieview-Palkbutte complex, § ta 40 percent north slopes Pravisional 75386
14 |Palygon 091 091 Bonnieview-Polkbutte complex, 8 to 40 percent north slopes Provisional TE3IEE - |

<]

»

o 0 2]

Shiow; I Al Selected | Records (0 out of 12496 Selected) Options v|

One way to create a new “musym” field with length of 6

Hame: oS TH

characteristics is to use the following steps:

¢ Open the attribute table. Click on the “Options”

button and select “Add Field”. Use a field name of

Alias: MU
Tvpe: IString
— Dizplay

I Turn Field off

I Use Field as Primary Display Field

[ e Eormats

“musym?2”. Set the field properties as “text “with a
length of 6.

wiN e Right click on the header of the musym2 field and

select “Field Calculator’. Set the field calculator to

— Data o
[Length (o )

| musym2 = MUSYM. This will calculate the new

field, including the musym’s that were not in the
NASIS legend.

e Delete the fields MUSYM and musym_1

ak. I Cancel

o ¢ Add a new field named “musym” as text with length

of 6. Calculate the field with criteria of musym =

musym2.

e Delete the musym2 field.
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13. The shapefile is now ready to use with Soil Data Viewer. Below is an example of an ecological
site ID map for the dominant condition created with Soil Data Viewer.

Soil Data Viewer is a useful tool for checking soil properties and interpretations spatially. It can
also be used to check consistency of soil properties and interpretations across subset survey
area boundaries.

The shapefile with mukey and the SSURGO Access database can be provided to users as
interim data products while the survey is progressing.

The Soil Data Viewer software and user guide are available at:

http://soildataviewer.nrcs.usda.gov/
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