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Exporting from CAD to HEC-RAS 

 

Stream centerlines and cross-sections obtained from survey or LiDAR data can be easily exported from 
AutoCAD Civil 3D to HEC RAS - there are a few tricks to note, though. This paper provides instruction on 
exporting from AutoCAD Civil 3D 2014/2016 to HEC-RAS 5.0.3. 

 

Stationing 

Typically, CAD stationing increases in the downstream direction. HEC RAS requires stationing to decrease in the 
downstream direction where Station 0+00 is at the downstream end of the reach and the largest station is at 
the upstream end of the reach.  CAD was designed for roadways, and thinks stations need to increase in the 
direction you draw an alignment.  RAS must have stations decreasing in the downstream direction and cross-
sections left to right looking downstream.   

 

 CAD process  

Summary: Create a surface in Civil 3D using survey and/or LiDAR data. Draw stream centerlines in Civil 3D from 
downstream to upstream. When creating alignment in CAD, the arrow should point upstream; this will ensure 
stationing decreases in the downstream direction in CAD. Draw in Reach Lines (polylines) on left and right 
banks and create alignments for them. Cut Sample lines (sections). Export to RAS. Then use FLIPPER 
spreadsheet before importing to RAS. Flow direction arrow should point downstream in RAS. 

Overview 
1. Import Survey Points + Lidar data 
2. Create Surface 
3. Draw 2-D polylines along channel centerline or thalweg and overbanks 
4. Create Alignments from 2-D polylines 
5. Create Sample Lines 
6. Save before exporting 
7. Export to HEC-RAS as .geo file 
8. Use RAS Flipper  

 
Step-by-Step 
After creating a surface, draw a polyline along the stream centerline from downstream to upstream. Draw in 
polylines along the left and right banks; these will be used in calculating reach lengths (distance between cross 
sections) in RAS. The polylines for the left and right banks can be drawn in any order, starting either upstream 
or downstream.  

 
After drawing the polylines for the centerline and banks, open the Alignment menu. Select Create 
Alignment from Objects, then click on the centerline polyline. The arrow should point upstream. If it 
doesn’t, type “R” in the command line to reverse. If you have drawn the centerline polyline from 
downstream to upstream, you should not need to reverse the stationing. Complete the alignment by 
clicking Enter again. 
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A window comes up, allowing you to name the alignment. Name your RAS alignment thoughtfully, so 
as not to confuse with design alignments. Be sure to uncheck the box that tells CAD to “Add curves 
between tangents”.  That functionality makes sense with roadway alignments, but not stream 
channels. 
 

 
 
   The new alignment should show stationing decreasing downstream. 

Now create “Sample Lines” for cross sections along the channel alignment.  
 

 
 

If the “Erase Existing Entities” box is 
checked, your polyline will be erased. 
Suggest unchecking this box, so you 
don’t have to redraw your polyline. 
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In the Create Sample Line Group window, name the sample line group and select the surface you want to 
sample from, if you have multiple surfaces. Uncheck the Sample box for a surface if you do not want to sample 
from that surface. 

 
 

There several ways to create samples lines. By “Range of Stations” is a quick way that generates 
straight line cross sections. If you need to dogleg cross sections, first draw polylines for your sections, 
then use “Select Existing Polylines” as the Sample Line creation method. Refer to the last page of these 
notes for advice on cross sections and why you may need to dogleg sections. 

 

 

Create Sample Lines By “Range of Stations”: 
 

• Select the Channel alignment you created. 
 

• Swath Widths refer to width of cross sections, i.e. 
left swath width of 100’ and right swath width of 
100’ creates 200’ wide sample line / cross section. 

 
• Sampling Increments specify how often cross 

sections will be cut along the alignment. 
 

• Set increments along tangents, curves and spirals 
so they are all the same value. 

 

     Additional Sample Controls: 
• Horizontal Geometry Points = False 
• Superelevation Critical Stations = False 
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After the sample lines are generated, use the grips to move sample lines around to capture the 
appropriate channel sections. Refer to the last page of these notes for advice on cross sections. 

 
It is recommended you cut and view cross-sections in CAD, before you export. You should always 
compare the sections in RAS with the CAD sections, to verify data imported correctly. 

 
After creating sample lines and sections views, SAVE before you export to RAS! 

 
Now for Exporting to HEC RAS – Under the Output tab, select “Export to HEC RAS”. 

 
 
Select the surface you want to sample from, and the alignment and samples lines just created. Site = None. 
Enter the River Name. Check River Banks box – when you click Left, CAD will prompt you to select a polyline or 
alignment – select your Left overbank alignment or polyline. Do the same for Right bank. Then Click Export. 
Make note of where you save the file. 
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The geometry file created by CAD requires some manipulation before importing to RAS, in order for the 
stationing, bank sections and aesthetic flow direction arrow to all be correct. There’s a spreadsheet macro – 
RASflipper - that takes a .geo file of RAS data exported from Civil 3D and flips it around so that it imports 
correctly into HEC RAS. It’s available here: 

 
https://www.nrcs.usda.gov/wps/portal/nrcs/detail/national/water/manage/hydrology/?cid=nrcseprd383438 
 
 
 

To use the RASflipper macro, open the spreadsheet, enable macros, and click the Flip ‘em! Button. Browse to the 
*.geo file created from the CAD export. The resulting file will have the same name as the Civil 3D export file with 
"Flipt" appended. 
 

https://www.nrcs.usda.gov/wps/portal/nrcs/detail/national/water/manage/hydrology/?cid=nrcseprd383438
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HEC-RAS Process 
 

Summary: Import the flipped geometry file and verify geometry is correct. 
 

Overview 
1. Open new project 
2. Import geometry (*flipt.geo file). 
3. Review sections in RAS to verify left bank and right bank looking downstream. 
4. Review and adjust reach lengths as necessary. 
5. Review and adjust bank stations as necessary. 

 
Step-by-Step 
From the File Menu in RAS, select New Project. Name your project and save to the appropriate folder. 

 
Then open the Geometric Data Editor by clicking the button or from the Edit menu → Geometric Data. 
 

 
 
 
 

In the Geometric Data editor, select File → Import Geometry Data → GIS Format. 
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Select the *Flipt.geo file just created. 
 
In the next window, set the RAS project units to US Customary Feet. Click Next through Intro, River Reach 
Stream Lines, and Cross Sections and IB Nodes. Click Finished – Import Data. 
 
The Centerline and cross sections with labels now appear in the Geometric Data Editor. The red dots indicate 
bank stations, defined as the point where the reach lines intersected the sample lines in CAD. Note that the 
arrow should point in the downstream direction and stationing should decrease downstream. 
 
Open the cross sections using the Editor buttons: 

 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Inspect the cross sections to verify geometry imported correctly. Compare to section views in CAD. 
Sometimes, if you don’t Flip the *.geo file, the cross sections will be reversed or the alignment 
reversed. Carefully look through several sections to verify. Look at more cross section by using the 
black arrows by River Sta. 
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In reviewing cross sections, also review the downstream reach lengths. Reach Lengths are the measured 
distances between cross sections: Left overbank (LOB), channel, right overbank (ROB). Overbanks should be 
measured along the path of the center of mass of the overbank flow. Reach lengths will differ significantly 
along river bends, channel meanders. LOB, Channel, and ROB reach lengths give RAS a length over which to 
apply the friction loss. The reach lengths are how HEC RAS understands meandering channel geometry.  
 
For example, if you have a river bending to the left, the LOB reach length will be the shortest and the ROB 
reach length will be the longest. Sometimes you have a fairly straight floodplain, while the main channel 
meanders around within that floodplain. In that case the main channel will have longer reach lengths than 
the overbanks. The instructions for measuring the LOB and ROB reach lengths is to follow the perceived 
"center of mass of flow" of the respective overbank. 
[Excerpted from The RAS Solution: http://hecrasmodel.blogspot.com/ ] 
 

 
 

 

 
 
 
 
 
 
 
 
 
 
 
 

Left Bank Right Bank 

Flip through cross-sections using the arrows 

http://hecrasmodel.blogspot.com/
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The locations where the reach length lines intersect the cross-sections is set to the bank station in RAS. Since 
generally we want the overbank flow reach length to be further out from the bank, these bank stations will 
need to be adjusted in RAS. It is most convenient to have Civil 3D compute all the flow reach lengths, and then 
in RAS move the bank stations, using the Graphical Cross-Section editor. 
 
In the Graphical XS Editor, move the bank stations by selecting the Set Bank Stations button and clicking on the 
node closest to the bank station. 

Graphical cross- 
section editor 



10  

 

Go through all cross sections to update bank stations and check reach lengths. 

 

After verifying that the cross sections are correct, save the geometry data in the Geometry Data Editor 
window. 

Save often! 

Once you’ve verified the geometry imported correctly and updated the bank stations, you are ready to add 
Manning’s n values and flow data. Then you’ll be ready to run the model! 

 
 
 

Resources: 

The RAS Solution: The Place for HEC RAS modelers 
http://hecrasmodel.blogspot.com/ 

 

HEC-RAS data from Civil 3D – NRCS H&H page: 
https://www.nrcs.usda.gov/wps/portal/nrcs/detail/national/water/manage/hydrology/?cid=nrcseprd383438 

 

NRCS HEC-RAS page: 
https://go.usa.gov/xXcRM 

 
Email the NRCS HEC-RAS team using the following Outlook user group: ug-LO-OR-NRCS-HECRAS 

 
 
 
Prepared by Meghan Walter, P.E. 
State Hydraulic Engineer – NRCS Oregon 
Meghan.Walter@or.usda.gov 
Updated March 2018 

http://hecrasmodel.blogspot.com/
https://www.nrcs.usda.gov/wps/portal/nrcs/detail/national/water/manage/hydrology/?cid=nrcseprd383438
https://go.usa.gov/xXcRM
mailto:Meghan.Walter@or.usda.gov
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How to draw cross sections 
Obtained from: http://hecrasmodel.blogspot.com/2012/07/how-to-draw-cross-sections.html 
Written by Chris Goodell, P.E., D. WRE | WEST Consultants 
Copyright © RASModel.com. 2012. All rights reserved. 

 
Cross sections must be perpendicular to the flow lines at all locations. And they cannot intersect with each 

other.  That is why it is common to see cross sections snap at different angles outside the main channel (we call 
this doglegging). The trick is to keep them from intersecting, while also staying perpendicular to flow lines. In 
the figure below, the dark blue line represents the main channel. The brown lines represent the edge of the 
flood plain. The light blue lines are my impression of the flow lines through this terrain, if water were flowing 
appreciably in the floodplain. The green lines are cross sections. Notice that the cross sections are drawn so 
that they are not only perpendicular to the main channel, but also to my perception of the flow lines in the 
floodplain.  It can be very helpful to draw these flow lines before cutting cross sections. 

 

 
It takes a little bit of practice to do this correctly, and most of the time some trial and error, but as long as you 

remain perpendicular to the flow lines and don’t intersect, you’ll have a good set of cross sections. 
 

A common questions – can you draw the cross section perpendicular to the contours on the left and right 
banks? Answer: That would be a good approximation if you are unable to draw flowlines, but theoretically, it 
should be perpendicular to the flowlines, not the contours. Flowlines are not always perpendicular to contour 
lines, particularly in areas contraction and expansion.

http://hecrasmodel.blogspot.com/2012/07/how-to-draw-cross-sections.html
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