Skip

Download and Install Soil Data Viewer

Version 6.1 requires soil data downloaded after July 16, 2013. Data downloaded prior to July 16 will only work with versions 5.0, 5.1, 5.2, and 6.0.

Download Soil Data Viewer 6.1 for use with ArcGIS 10 or 10.1, and either Windows 7 or Windows XP Professional.

Download Soil Data Viewer 6.0 for use with ArcGIS 10, and either Windows 7 or Windows XP Professional.

Download Soil Data Viewer 5.2 for use with ArcGIS 9.2 or later.

Download Soil Data Viewer 5.1 for use with ArcGIS 9.0 or 9.1.

Download Soil Data Viewer 5.0 for use with ArcGIS 8.3.